L3DT users' community
Large 3D terrain generator

A bugfix for dual/quad-core systems

Important stuff.

A bugfix for dual/quad-core systems

Postby Aaron » Thu Jan 03, 2008 12:47 am

Hi Everyone,

In L3DT release 2.5b there were some non-threadsafe sections in the mosaic cache management system that were causing problems on multi-core systems, particularly when generating high-resolution textures, light maps and normal maps. I've spent a few days on this, and I think it's all now in order. If you have a dual or quad-core system and have been experiencing problems with L3DT Pro, please download the latest developmental build on the Pro downloads page (v2.5b build 26, 3rd of Jan '08). If this developmental build works OK for everyone, the fix will be included in the upcoming L3DT release v2.5c.

If you have a quad-core machine, you should now see four yellow dots when generating the texture map, which indicates four active threads (as below).

Image

If you do not see all fore cores running, then it is probable that you need to overwrite some residual settings from older versions of L3DT. To do this, save your project and close L3DT. Then, download this text file, and drag-and-drop it onto the L3DT desktop icon. L3DT will ask you if you want to apply the settings patch; click 'yes'. You may then re-load your project and continue with your terrain building.

Please let me know if there are any problems.

Cheerio,
Aaron.

PS: Please note that this dev build also includes the new texture material system, as described back in November.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby Ch3rokee » Thu Jan 03, 2008 12:31 pm

Hello Aaron, my free updates ended the 12 of December and I downloaded this Dev Build to see how that's handled by L3DT, and when I opened it, L3DT said "Your registration code has been corrupted! Please re-enter your activation code.". If you enter the old one it show the error log with: CVarList::Create error
- Name '44' is already in use
And then it says the correct thing, that this code is not for this version.
So maybe It would be better if it said that you need to purchase another license or return to an older build.

Anyway, thank you for the great updates up to this day.
User avatar
Ch3rokee
Contributing member
 
Posts: 32
Joined: Sat Jun 10, 2006 10:38 am


Return to Announcements

Who is online

Users browsing this forum: MSN [Bot] and 3 guests

cron