L3DT users' community
Large 3D terrain generator

Quick info report for L3DT Pro 15.05.0.2 (Dev)

Any and all chit-chat regarding L3DT.

Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Kiwi-Hawk » Thu Jun 18, 2015 3:16 am

Kia ora

When paunting I get a lot of runn away brush's where the brush wont stop and throws a log:

CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised

I'm doing this on my:

i7 4770 6 core with 32 Gb ram and a G-forece 970 (4GB version)

BTW
Wher/who does this painting get used I don't seem to see it update the textures in 3D mode after painting
or do we need a rebuild feature that rebuilds ALL maps if change's are made, refresh does not seem tp do that.

For example of I see an area I wish to alter and use the raise/lower etx to make those changes I find I need to close
all pages and rebuild to see those change's, am I missing something, maybe a script
Kiwi-Hawk
Contributing member
 
Posts: 34
Joined: Sat Jan 31, 2015 9:43 pm

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Aaron » Thu Jun 18, 2015 11:37 am

Hi Kiwi-Hawk,

I apologise for this error, and thank you for the bug report.

Can you please send me the log file after you get the brush error? You can get to it using the 'All programs->Bundysoft->L3DT [version]->L3DT logs' shortcut in the Windows start menu. That link will open a directory in which you will find a file called 'log.txt'. Please send it to aaron@bundysoft.com. With the logfile, I should be able to work out what is going wrong. Please collect the log file after the fault occurs in L3DT, and before re-opening the program, as the log file is overwritten at the start of each session.

Wher/who does this painting get used I don't seem to see it update the textures in 3D mode after painting
or do we need a rebuild feature that rebuilds ALL maps if change's are made, refresh does not seem tp do that.


The rebuild of the other maps doesn't happen automatically because on large maps it could take a really long time, and L3DT can't know whether the user intends to do more editing or some other operations before rebuilding the texture &c. Instead, after you've finished your editing, select the 'calc' button on the toolbar (or the 'Operations->Calculation wizard' menu item) to open the calculation wizard, then select all the maps you want to rebuild (usually everything beneath the heightfield, if you've been editing the heightfield).

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3655
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Kiwi-Hawk » Thu Jun 18, 2015 12:21 pm

Kia ora

Is this what your looking for? please find attachment (I hope)
Attachments
log.7z
(145.45 KiB) Downloaded 162 times
Kiwi-Hawk
Contributing member
 
Posts: 34
Joined: Sat Jan 31, 2015 9:43 pm

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Aaron » Thu Jun 18, 2015 2:12 pm

Hi Kiwi-Hawk,

Thanks for the log file. I can definitely stop the mouse capture sticking on, but I'm not quite sure why the edit record is being re-initialised before it has been finalised from the last edit. This looks like it might be a race-condition, which is a bit nasty. I'll have a bit more of a look around, and add a lot of debugging statements, then upload a new version for you. This might take a day or two.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3655
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Kiwi-Hawk » Fri Jun 19, 2015 12:33 am

No rush mate Rome wasn't built in a day and I hear the world took 7 lol
Kiwi-Hawk
Contributing member
 
Posts: 34
Joined: Sat Jan 31, 2015 9:43 pm

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Aaron » Fri Jun 19, 2015 2:08 pm

Hi Kiwi-Hawk,

Thank you for your patience. On the pro downloads page now (please consult sales/registration e-m,ail for link) you should find a new developmental build (15.6.0.1), which will partially fix this problem. I'm not sure I've worked out why the edit record was being re-initialised before begin finalised, but I've made it so that the mouse capture is released immediately when this error occurs, and I've also added a lot of debugging statements to the logfile so that I may be able to work out the root cause. Please download it and give it a go, and let me know what you find.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3655
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Kiwi-Hawk » Tue Jun 23, 2015 5:06 am

Kia ora

Doing a random island for you as a test and just di a rebuild catching this error, will atach the log too

CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
- requested record 'Edit HF', current record 'Edit HF'
zbackup_EditRecord_Init error:
- call to 'L3DTio_Backup.EditRecord.Init' failed
CSapphireWnd::OnLButtonDown error:
- cannot create edit record (HF)
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
- requested record 'Edit HF', current record 'Edit HF'
zbackup_EditRecord_Init error:
- call to 'L3DTio_Backup.EditRecord.Init' failed
CSapphireWnd::OnLButtonDown error:
- cannot create edit record (HF)
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTio_BackupApp::InitEditRecord error:
- edit record is already initialised
- requested record 'Edit HF', current record 'Edit HF'
zbackup_EditRecord_Init error:
- call to 'L3DTio_Backup.EditRecord.Init' failed
CSapphireWnd::OnLButtonDown error:
- cannot create edit record (HF)
calc_LM_lighting warning:
- bump mapping was already applied to the normals map
ExtFunc_var_Delete error:
- cannot get var parent for type=11/string name='' (in L3DTio_FI.zeo)

Thanks for all you do, hope this is of help
Attachments
log.7z
(311.08 KiB) Downloaded 161 times
Kiwi-Hawk
Contributing member
 
Posts: 34
Joined: Sat Jan 31, 2015 9:43 pm

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Kiwi-Hawk » Fri Jun 26, 2015 1:33 am

Kia ora

Got a lot of this while trying to hand paint in the design map area
Making sea amd mountians. cliff etc

CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
CL3DTView::RedrawBufferRegion error:
1024x1024, 4096x4096
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = -1, x2 = 15, y1 = 183, y2 = 199
- tx1 = 0, tx2 = 63, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = 1, x2 = 17, y1 = 178, y2 = 194
- tx1 = 64, tx2 = 127, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = -3, x2 = 13, y1 = 183, y2 = 199
- tx1 = 0, tx2 = 63, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = -3, x2 = 13, y1 = 182, y2 = 198
- tx1 = 64, tx2 = 127, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = -5, x2 = 11, y1 = 182, y2 = 198
- tx1 = 0, tx2 = 63, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = -7, x2 = 9, y1 = 177, y2 = 193
- tx1 = 64, tx2 = 127, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = 7, x2 = 23, y1 = 177, y2 = 193
- tx1 = 0, tx2 = 63, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = 9, x2 = 25, y1 = 180, y2 = 196
- tx1 = 64, tx2 = 127, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = 10, x2 = 26, y1 = 195, y2 = 211
- tx1 = 0, tx2 = 63, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64
L3DTio_BackupApp::AddMapAreaToEditRecord error:
- x coords are invalid
- x1 = 2, x2 = 18, y1 = 189, y2 = 205
- tx1 = 64, tx2 = 127, ty1 = 256, ty2 = 255
- tnx = 256, tny = 256
- mask res = 64



BTW thanks for your efforts, and I hope it's ok to post like this not sure about the right wayto do these reports
Attachments
log.7z
Current log from the time of lat errors
(39.97 KiB) Downloaded 155 times
Kiwi-Hawk
Contributing member
 
Posts: 34
Joined: Sat Jan 31, 2015 9:43 pm

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Aaron » Wed Jul 15, 2015 1:58 pm

Hi Kiwi-Hawk,

Sorry for the delay. That's a formidable logfile to work through (18,000 lines!)

think the 'CL3DTView::RedrawBufferRegion' errors were related to you manually deleting each map layer one by one before modifying the design map. As you did so, L3DT had to keep re-drawing the main window with the next highest map in the layer list. Once you cleared the salinity map, the renderer for the water map (which was next in line) got a bit snotty because it required the salinity map that you had just closed. I'll see if I can make this more fault tolerant.

Anyway, it's not necessary to manually delete each map layer when you tinker with the design map. When you modify the design map, L3DT will automatically flag the later maps as begin invalid, and will mark them for recalculation. If the invalid maps are not re-calculated before saving the project, the invalid map layers are discarded.

I'm still looking into the 'L3DTio_BackupApp::AddMapAreaToEditRecord'. On the face of it, it looks like some bad coordinates were passed through to the undo plugin. I'm not quite sure why yet,

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3655
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Quick info report for L3DT Pro 15.05.0.2 (Dev)

Postby Aaron » Wed Jul 15, 2015 3:13 pm

Hi Kiwi-Hawk,

I think I've fixed this in L3DT Pro 15.07 build 2, which is on the Pro downloads page now. Please let me know if problems persist.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3655
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia


Return to General discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron