L3DT users' community
Large 3D terrain generator

Sapphire bug and tiled texture issue?

Got a problem or need advice?

Sapphire bug and tiled texture issue?

Postby Acoustic » Sun Jun 04, 2017 10:14 pm

http://imgur.com/qThXYJ0

Link to a pic of my issue.

As you can see where the cursor is, I am having issues with the desert climate tiling textures and sapphire is not loading texture's correctly either.
Acoustic
Member
 
Posts: 13
Joined: Fri Apr 24, 2015 3:07 am

Re: Sapphire bug and tiled texture issue?

Postby Acoustic » Wed Jun 07, 2017 11:19 pm

Any idea?
Acoustic
Member
 
Posts: 13
Joined: Fri Apr 24, 2015 3:07 am

Re: Sapphire bug and tiled texture issue?

Postby Aaron » Sun Jun 11, 2017 3:30 pm

Hi Acoustic,

I'm very sorry for the delay in my reply.

The issue with Sapphire is that it only supports texture resolutions that are a power of two, which makes it easier to calculate mipmaps and manage tiling. I could conceivably have sapphire re-pack the texture to make it fit the size requirements, but this would be awfully slow when opening and closing Sapphire (a copy and resize when coming and going). If you require the use of Sapphire, my recommendation would be to generate the attributes map / normals / light map / texture use the next largest power of two (8), and then, if you really need a resolution of 6 for use in another program, use the export wizard to change the size during export without affecting the data in the project.

I'm not sure about the texture repeating artefact. I'll have to test this further.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3613
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Sapphire bug and tiled texture issue?

Postby Acoustic » Sun Jun 11, 2017 10:57 pm

Right on. The tiling issue is a big roadblock so if anything is found out let me know. No rush. Thanks.
Acoustic
Member
 
Posts: 13
Joined: Fri Apr 24, 2015 3:07 am


Return to Help and support

Who is online

Users browsing this forum: No registered users and 1 guest