L3DT users' community
Large 3D terrain generator

Loading mgf Log Error

Please report software faults here.

Loading mgf Log Error

Postby monks » Wed Nov 23, 2005 3:55 pm

Hi Aaron,
when opening up an .mgf from the recent list (at the bottom of the File menu) I get error log

CVarList::Create error
- Tag '4' already in use

CVarList::CreateData error:
- Create returned false

CVarList::Create error
- Tag '10' already in use

CVarList::CreateData error:
- Create returned false


- even though the mgf opens up fine from File>Open

In this particular mgf when it is open I don't have the option of View> Show Map for water salinity and Light map. Just thought I'd mention that as I don't know if that's usual.

I get the same results for the two seperate mgfs that I have on disk- completely different projects. Clean start ups of L3DT too. Latest version.
I close the dialog and it says 'Ready' but there is nothing loaded.
monks
Oracle
 
Posts: 292
Joined: Tue Nov 22, 2005 10:38 pm
Location: Middle Earth

Re: Loading mgf Log Error

Postby Aaron » Wed Nov 23, 2005 11:56 pm

Hi Monks,

monks wrote:Hi Aaron,
when opening up an .mgf from the recent list (at the bottom of the File menu) I get error log...


Ah, that's a know fault. I've never actually wired-up the most-recent-used (MRU) list in the file menu. It's on the to-do list.

In this particular mgf when it is open I don't have the option of View> Show Map for water salinity and Light map. Just thought I'd mention that as I don't know if that's usual.


This is a dumb question; do those maps exist? If in doubt, look in the .mgf (it's a text file) to see whether there are entries for 'WS' and 'LM' under the ** files in group ** heading.

I get the same results for the two seperate mgfs that I have on disk- completely different projects. Clean start ups of L3DT too. Latest version.
I close the dialog and it says 'Ready' but there is nothing loaded.


Could you post the contents of one of these map group files so we can pick over it? That would help a lot.

Cheers,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby monks » Thu Nov 24, 2005 7:49 pm

- apart from the known issue everything is fine.
I have a few interrelated projects on the go and I've not necessarily being using the NEXT wizard for generating the various maps, so I probably just didn't generate those maps. The map files are there (except the salinity but there was no sea on the map).

monks
monks
Oracle
 
Posts: 292
Joined: Tue Nov 22, 2005 10:38 pm
Location: Middle Earth

Postby Aaron » Wed Jan 11, 2006 2:41 am

aaron wrote:Ah, that's a know fault. I've never actually wired-up the most-recent-used (MRU) list in the file menu. It's on the to-do list.


Done, the fix is in L3DT 2.3c.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 3 guests

cron