L3DT users' community
Large 3D terrain generator

3d view gives error

Please report software faults here.

3d view gives error

Postby creekmonkey » Mon Sep 21, 2009 8:29 pm

When I try to view my terrain in 3d I get this error

CSapphireWnd::ShowWnd error:
- OpenGL 2.0 is not supported on your system. Please update drivers.

I ran the opengl extension viewer, which says my opengl driver is 1.4.

I am using the standard version. I had previously used L3DT successfully with an older version. Also the pro trial version didnt give this error. Any Help?
creekmonkey
New member
 
Posts: 4
Joined: Mon Sep 21, 2009 8:24 pm

Postby Aaron » Tue Sep 22, 2009 1:25 am

Hi Creekmonkey,

Newer versions of the Sapphire renderer use OpenGL 2.0 because it adds support for texture sizes that are not powers of two.

I suggest you update the drivers for your graphics card or chip. You can download drivers for NVIDIA from here, for ATI / AMD from here, and for other vendors from their respective websites.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3687
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby creekmonkey » Tue Sep 22, 2009 3:18 am

Thanks aaron. I did update driver but some of my other software would not function with the updated driver (go figure). I found an older realease of L3DT v2.5c standard which I still had. That will have to do for now.
creekmonkey
New member
 
Posts: 4
Joined: Mon Sep 21, 2009 8:24 pm


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 2 guests