L3DT users' community
Large 3D terrain generator

[v2.8 build 16] Incorrect Attribute Map Progress

Please report software faults here.

[v2.8 build 16] Incorrect Attribute Map Progress

Postby David Walters » Fri Mar 19, 2010 11:38 pm

Hi Aaron, I'm currently building the attribute map at 4x quality for a large terrain of size 3712 × 7680.

It's currently at the stage of 'calculating land types' and it seems that both the time estimate and percentage progress shown in the main window are using what appears to be more like the width of the terrain squared instead of width * length. This was apparent when, as it has just got past what looks like 1/3 of the length of the map the progress went from 98, 99%, etc. to blank and the time is now showing 'Indeterminate'. Looks like I've got a bit longer to wait :)

It's not a big problem, but hopefully it's also pretty easy to fix. I should point out I haven't tried other maps with other ratios so I hope this isn't just a random occurrence!

One thing I'd also like to mention is that support for multiprocessing is really needed for this stage. You probably already know (I think it's on your todo list even) so I don't want to grumble too strongly. However it is by far the slowest part of any map creation for me, and I guess I've been spoiled by the speed of the other stages on my Q6600, but it'd be great if this was tackled soon.
David Walters
Doyen
 
Posts: 128
Joined: Fri Apr 24, 2009 1:10 pm

Postby Aaron » Sat Mar 20, 2010 6:32 am

Hi David,

The attributes map calculation has two stages when generating high-res attributes maps. The progress bar goes from 0->100 for each of the stages, and at the changeover point the time estimate becomes indeterminate for a little while (it will recover). The two stages of the calculation have different rates (i.e. pixels/second), so it's difficult to accurately pretend they're one large calculation and properly estimate the total time. I may revisit this in the future, but for now, let's call it a 'feature'.

I agree completely re: multithreading the attributes map calculation. It's intended to be one of the headline changes in v3. Non-trivial refactoring, unfortunately.

Cheerio,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3687
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby David Walters » Sat Mar 20, 2010 9:18 am

Okay, thanks for the explanation. FWIW It took an additional 3.5 hours after I posted and stayed 'indeterminate' the whole time. But I'll know for next time now so I don't really need the timer all that much - I'll just go to bed :)

If this is a major v3 level change to use multithreading (which I feared would be the case) then that's fine, I can plan around this being an expensive operation. Luckily lightmap and texture generation are really really fast once it's done that!
David Walters
Doyen
 
Posts: 128
Joined: Fri Apr 24, 2009 1:10 pm


Return to Bug reports

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest

cron