L3DT users' community
Large 3D terrain generator

Attributesmap mask overlay fails

Please report software faults here.

Attributesmap mask overlay fails

Postby HorribleGoat » Sat Mar 10, 2018 6:01 pm

Hello,

I recently found good use of the mask overlay to recalculate specific areas of my terrain with "myClimate - auto-calc"

unfortunately out of the blue the mask overlay stopped working most of the time couple of days ago and I have not been able to produce tangible reason why it does not work.

it spams this into log:

calc_AM_GenPixel2 error:
- cannot get WSpxl
CMapWrap::LinInterp error:
- map not initialised.

I have made multiple test terrains and sometimes some mask images work on some of them and sometimes not.

I have tested with multiple climates, with and without my custom climate being loaded up.

running:

Version: 17.11 Pro x64 dev build 1
Build date: 30-Nov-2017

and have tested on previous versions too and on another computer.
User avatar
HorribleGoat
New member
 
Posts: 6
Joined: Sat Oct 06, 2012 4:57 pm

Re: Attributesmap mask overlay fails

Postby Aaron » Wed Mar 14, 2018 12:55 pm

Hi HorribleGoat,

I apologise for the delay, and for this inconvenience.

The attributes map calculation is expecting the salinity map to be initialised, which is clearly not the case in some of your maps (it will depend on whether sea is present, and whether you've performed water table modelling). This error occurs regardless of whether the land types being re-calculated have any salinity dependence. The calculation should work out if it really needs the salinity map, and either fail immediately or continue quietly.

I'm testing a fix now, which seems to work so far. I'll put it in a new dev build in the next day or so, once I'm reasonably sure I haven't broken anything else.

The good news is that there is also a work-around, and that it is pretty simple. Go to 'Layers->New map layer' in the menu, and define a new layer called 'WS' with a type 'heightfield', like below:

defining_ws.png
defining_ws.png (32.76 KiB) Viewed 2205 times


(please don't change the layer size settings; these have to match the heightfield, which they do by default)

With this map layer now defined, the calculation should proceed as normal.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3681
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Attributesmap mask overlay fails

Postby Aaron » Fri May 04, 2018 3:02 pm

Hi HorribleGoat,

The issue with the mask overlay should now be fixed in L3DT v18.05 build 1, which is on the downloads page now. Please let me know if problems persist. Thank you for the bug report, and sorry again for the delay.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3681
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Attributesmap mask overlay fails

Postby HorribleGoat » Wed May 23, 2018 8:58 pm

Hey Aaron!

Great to hear from you and sorry I did not notice you had replied!

I'll test the new version as soon as I can and report back!
User avatar
HorribleGoat
New member
 
Posts: 6
Joined: Sat Oct 06, 2012 4:57 pm

Re: Attributesmap mask overlay fails

Postby HorribleGoat » Thu May 24, 2018 12:45 am

Ok tested the mask overlay and it works now again! Which is awesome so thank you very much!

I'll do more in depth testing later when I have proper time to do so!
User avatar
HorribleGoat
New member
 
Posts: 6
Joined: Sat Oct 06, 2012 4:57 pm


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron