L3DT users' community
Large 3D terrain generator

Sapphire crashing

Please report software faults here.

Sapphire crashing

Postby HorribleGoat » Sat Oct 06, 2012 5:54 pm

Hi!

I recently updated to 12.06 because my previous version kept crashing while I exported attributes and texture maps (20480x20482px images) and though that works now I've encountered a new problem.

Im working on a 20x20km map and lately sapphire has begun crashing when Im trying to edit the heightfield.

2048x2048 heightfield with horizontal scale of 10

At sapphire startup it flashes the log window but it doesn't stay. I can move around and use the tools for a while and can work on a small area, but if I move out too much it crashes. Also the wireframe view shows that the terrain verticles are quite large and they don't divide to smaller for details. (this has worked before)

I tried to record as much as possible of what happens when I move arounf in 3D and got couple of shots what happens before it crashes.

First one is when sapphire loads up, nothing spectacular, but when I move around at certain points and camera angels it flashes the more detailed mesh a few times and the it crashes (pic 2 just before crash)

Im also sending the logfiles vie Email

Hopefully they are helpful and there might be a solution for this soon as L3DT has been awesome tool for map making but I have to put my project on hold on the map tweaking part until this works out.

Thanks Aaron for amazing work!

HG

sapphire_crash_1.jpg
Sapphire at startup
sapphire_crash_1.jpg (198.55 KiB) Viewed 4701 times


sapphire_crash_2.jpg
Right before crash
sapphire_crash_2.jpg (213.95 KiB) Viewed 4701 times
User avatar
HorribleGoat
New member
 
Posts: 7
Joined: Sat Oct 06, 2012 4:57 pm

Re: Sapphire crashing

Postby Aaron » Mon Oct 08, 2012 9:49 am

Hi HorribleGoat,

Thanks for the bug report and for the log files. I'm looking into it now.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Sapphire crashing

Postby Aaron » Mon Oct 08, 2012 11:25 am

Hi HorribleGoat,

I'm having a bit of difficulty in reproducing this fault. Can I ask you to please try the latest build on the downloads page, which is 12.10 build 0 (uploaded 8th of Oct)? This version includes some additional logging that should help in tracking down this fault.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Sapphire crashing

Postby HorribleGoat » Tue Oct 09, 2012 7:12 pm

I got it working with my current build by setting the big imagemaps to use tiling properly, must have done something wrong with that before.

I'll try to reproduce the problem with the latest build tho when I get a chance!

Thanks Aaron!
User avatar
HorribleGoat
New member
 
Posts: 7
Joined: Sat Oct 06, 2012 4:57 pm


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron