L3DT users' community
Large 3D terrain generator

frustrating bug when moving around in sapphire

Please report software faults here.

frustrating bug when moving around in sapphire

Postby mcbeth » Sun Mar 24, 2013 7:33 pm

If move in a direction for to long.....it suddenly just keeps going in that direction and wont stop.......I have to quite literally pound on my keyboard for it to stop.......even if I exit sapphire and re-enter the motion state is returned..........the keys on my keyboard are not sticking, I checked that also, I use L3DT_PRO_dev-12.12.0.0 ....is this known...is it fixed...or could it be something in my side
mcbeth
Contributing member
 
Posts: 45
Joined: Wed Jun 27, 2007 10:01 pm

Re: frustrating bug when moving around in sapphire

Postby mcbeth » Fri Apr 12, 2013 1:00 am

I guess I'm the only one getting this, I've even updated the build and the issue persists, it's not the keyboard because the issues happen in any direction I move it like the move state some how gets stuck and then becomes a real fight to stop it.....it making editing terrain in 3d a real pain for me

any help will be appreciated ..........also the map I am working on is quite large so there is stuttering may is is a memory thing but I really need some clues

edit might be really be a state getting "stuck" or corrupted in memory, it doesn't seem to happen if there is little to no stuttering when loading the terrain blocks, like when fog and or textures are turned off and it also happens in attribute paint mode, but it definitely always starts during short freezes that occur when L3dt's rendering resources are heavily taxed.
mcbeth
Contributing member
 
Posts: 45
Joined: Wed Jun 27, 2007 10:01 pm

Re: frustrating bug when moving around in sapphire

Postby Aaron » Fri Apr 12, 2013 2:40 pm

Hi McBeth,

I apologise for this fault, and for the delay in my reply. This is a known problem, and occurs when the Sapphire window doesn't receive the WM_KEYUP message when the direction key is released. This seems to happen more often when the renderer is heavily taxed from high triangle counts or from texture paging. Releasing the affected key and pressing it again should cancel the motion. I will look into a proper solution to this fault as soon as possible. Thanks for the bug report.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3687
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: frustrating bug when moving around in sapphire

Postby mcbeth » Fri Apr 12, 2013 10:27 pm

oh ok thanks but it really does not stop many times for me, it will just keep going and going even if u stop and restart sapphire..............I often have to wildly press keys to get it to stop use "baby steps" on large map it slows u down considerably but I guess I'll have to make do until a fix....just needed confirmation that is not a problem on my side.
mcbeth
Contributing member
 
Posts: 45
Joined: Wed Jun 27, 2007 10:01 pm

Re: frustrating bug when moving around in sapphire

Postby Aaron » Mon Apr 15, 2013 1:38 pm

Hi McBeth,

I'm pretty sure this is a problem in Sapphire and not on your side. I've included a fix in the next build of Sapphire, and I'll post back here when it's available for download. I'm in the middle of working on some other parts of Sapphire right now, so it'll take me a few days to get the panels back on, as it were.

Thanks again for the bug report.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3687
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: frustrating bug when moving around in sapphire

Postby mcbeth » Wed Apr 17, 2013 1:41 pm

ok thanks, as said I'll make do until it is fixed
mcbeth
Contributing member
 
Posts: 45
Joined: Wed Jun 27, 2007 10:01 pm

Re: frustrating bug when moving around in sapphire

Postby Aaron » Sun Apr 28, 2013 1:17 pm

Hi McBeth,

The fix is now available in L3DT Pro 13.04 build 1, which is on the downloads page now. Please let me know if any problems persist.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3687
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: frustrating bug when moving around in sapphire

Postby mcbeth » Tue Jul 23, 2013 1:09 am

thanks been inactive for a while school and work taking it toll I'll download this and test time allowing

thanks so much
mcbeth
Contributing member
 
Posts: 45
Joined: Wed Jun 27, 2007 10:01 pm


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron