L3DT users' community
Large 3D terrain generator

Low CPU usage during erosion in 15.11 dev 3

Please report software faults here.

Low CPU usage during erosion in 15.11 dev 3

Postby wdhwg001 » Tue Dec 29, 2015 3:45 am

CPU: Intel i7 5775C 3.3Ghz
Memory: 24GB
OS: Windows 10 x64 TH2

When Creating heightmap, the CPU usage is only about 20%, even when the L3DT.exe is in High priority.

Seems this issue also happens in the standard version 15.11.

I'm using L3DT to create large landscape(eg. 8192*8192), it takes a long time so I'm wondering if there is a fix.

Thanks.
wdhwg001
New member
 
Posts: 3
Joined: Tue Dec 29, 2015 3:36 am

Re: Low CPU usage during erosion in 15.11 dev 3

Postby Aaron » Tue Dec 29, 2015 11:17 am

Hi wdhwg001,

I apologise for this inconvenience. The heightfield generation algorithms in L3DT are not multi-threaded, so during heightfield generation you should expect only one core to be at full utilisation. Hence, for these calculations the overall system CPU utilisation will be approximately 1/n, where n is the number of cores.

The calculations that have been multithreaded are those that are the most CPU intensive and take the most time; namely generating the attributes map, normal map, light map (shading, not shadow casting), and texture map. It is on my to-do list to re-write some of the heightifeld algorithms to be multi-threaded also, but I do not yet have a definite timeframe.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3680
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 4 guests

cron