L3DT users' community
Large 3D terrain generator

2.9 looping texture desert problem

Please report software faults here.

2.9 looping texture desert problem

Postby yrgol » Sun Sep 05, 2010 4:04 pm

2.9 fixed most of my looping texture problems, but I'm still having trouble with the sand in the desert. The other textures seem to work fine. I've attached a picture of the texture repeated in photoshop.

I used high res attributes, textures, normals, and lightmap. Also anti-aliasing. I have not tested if changing any of these settings makes a difference. Looping works perfectly in the temperate climate.

Image[/img]
yrgol
New member
 
Posts: 7
Joined: Sat Nov 21, 2009 3:54 pm

Postby yrgol » Sun Sep 05, 2010 4:09 pm

Seems to be a problem in the lightmap. I see the same seam when I do the same experiment with just the light texture.
yrgol
New member
 
Posts: 7
Joined: Sat Nov 21, 2009 3:54 pm

Postby yrgol » Sun Sep 05, 2010 4:31 pm

Only happens when I enable bump mapping.
yrgol
New member
 
Posts: 7
Joined: Sat Nov 21, 2009 3:54 pm

Postby Aaron » Mon Sep 06, 2010 9:04 pm

Hi Yrgol,

Thanks for the bug report. Are you using the stock climates and materials, or is this a custom material? If this is the stock materials, can you please send me your project's map definition file ([mapname].def.xml) so that I can test the settings you are using? (please send to aaron@bundysoft.com) I've not been able to reproduce this fault, but perhaps I'm not using the right settings.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby yrgol » Tue Sep 07, 2010 1:42 am

Yeah everything is stock. I sent the definition file.
yrgol
New member
 
Posts: 7
Joined: Sat Nov 21, 2009 3:54 pm

Postby Aaron » Thu Sep 09, 2010 11:24 am

Hi Yrgol,

I apologise for the delay, and thank you for the map definition file.

The problem here is that the bump map for the 'deep desert' material is 512x512 pixels in size, and won't wrap neatly if the heightfield is not a multiple of 512x512 pixels (yours is 256x256 pixels). One solution is to use a larger heightfield size, the other is to use this modified material file:

http://www.bundysoft.com/L3DT/downloads/temp/Desert_Deep%20desert.mat.xml

This file can be copied over the existing material of the same name.

In this modified material file I have changed the texture scaling to ensure that you can still use 256x256 pixel heightfields at 16x and 32x resolution without seams when wrapping.

Please let me know if problems persist.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby yrgol » Sat Sep 11, 2010 2:33 am

Awesome, thanks. I have not had a chance to test it yet but it sounds likely.
yrgol
New member
 
Posts: 7
Joined: Sat Nov 21, 2009 3:54 pm

Postby yrgol » Mon Oct 04, 2010 6:52 pm

Replacing that file did not seem to help. Changing the heightfield size to 512 does.
yrgol
New member
 
Posts: 7
Joined: Sat Nov 21, 2009 3:54 pm


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 0 guests

cron