L3DT users' community
Large 3D terrain generator

Mesh decimator error

Please report software faults here.

Mesh decimator error

Postby galaxyboy » Fri Apr 15, 2011 5:57 pm

Hi!

I am new to this forum.
I really want to try out L3DT but I get a crash every time I want to export to obj/3ds or if I want to open the 3D view.

I have attached my error log.

When I choose export, enter the file name and click on "Save" I get a popup window stating:
----------------------------------------------------------------------------
CDeciHF::InitData error:
- cannot allocate triangle pool

atMeshDecimator::DecimateUI error:
- cannot initialise decimator heightfield

CL3DTio_OBJ::SaveMapDecimated error
- mesh decimator failed

CL3DTio_OBJ::ExtSaveMeshUI error:
- call to SaveMapDecimated failed

CDeciHF::InitData error:
- cannot allocate triangle pool

atMeshDecimator::DecimateUI error:
- cannot initialise decimator heightfield

CL3DTio_OBJ::SaveMapDecimated error
- mesh decimator failed

CL3DTio_OBJ::ExtSaveMeshUI error:
- call to SaveMapDecimated failed
----------------------------------------------------------------------------

And the last rows of the log file:
----------------------------------------------------------------------------
CZeoFunc::CallFunction error:
- The function 'SaveMeshUI' in the plugin 'L3DTio_OBJ' returned an error.
CzCodeBlock::ExecuteFunc error:
- call to zeofunc_Execute2 failed
CzCodeBlock::Execute error:
- call to ExecuteFunc failed
CzCodeBlock::ExecuteChildBlock error:
- call to child block Execute failed
CzCodeBlock::ExecuteChildren error:
- call to ExecuteChildBlock failed
CzCodeBlock::Execute error:
- call to ExecuteChildren failed
ZeoScript::RunScript2 error:
- call to CzCodeBlock::Execute failed
CZeoFunc::CallFunction error:
- The function 'ExtRunScript2' in the plugin 'ZeoScript' returned an error.
atMeshDecimator::DecimateUI - initialising DeciHF
CDeciHF::InitData - allocating tri pool

CDeciHF::InitData error:
- cannot allocate triangle pool


atMeshDecimator::DecimateUI error:
- cannot initialise decimator heightfield

CDeciHF::FreeData
CDeciHF::RoamFreePatches
CDeciHF::FreeData - done
CZeoFunc::CallFunction error:
- The function 'DecimateUI' in the plugin 'atMeshDecimator' returned an error.

CL3DTio_OBJ::SaveMapDecimated error
- mesh decimator failed


CL3DTio_OBJ::ExtSaveMeshUI error:
- call to SaveMapDecimated failed

CZeoFunc::CallFunction error:
- The function 'SaveMeshUI' in the plugin 'L3DTio_OBJ' returned an error.
CzCodeBlock::ExecuteFunc error:
- call to zeofunc_Execute2 failed
CzCodeBlock::Execute error:
- call to ExecuteFunc failed
CzCodeBlock::ExecuteChildBlock error:
- call to child block Execute failed
CzCodeBlock::ExecuteChildren error:
- call to ExecuteChildBlock failed
CzCodeBlock::Execute error:
- call to ExecuteChildren failed
ZeoScript::RunScript2 error:
- call to CzCodeBlock::Execute failed
CZeoFunc::CallFunction error:
- The function 'ExtRunScript2' in the plugin 'ZeoScript' returned an error.
----------------------------------------------------------------------------

Do you know what the problem is??
galaxyboy
Newbie
 
Posts: 1
Joined: Fri Apr 15, 2011 5:47 pm

Re: L3DT Standard 2.9.0.12

Postby icckleblackcat » Fri Apr 22, 2011 7:33 pm

Ditto here.. exact same problem essentially identical logs.
icckleblackcat
Newbie
 
Posts: 1
Joined: Thu Apr 21, 2011 11:07 pm

Re: L3DT Standard 2.9.0.12

Postby Aaron » Fri Apr 22, 2011 11:53 pm

Hi Guys,

I apologise for this error. Can I ask you to please send me your log files? To find the log file, go to the Windows Start menu and click on the following item:

All programs->Bundysoft->L3DT [version]->L3DT logs

This will open a directory containing 'log.txt' and 'debug.dat' (L3DT Pro only). Please send these files to aaron@bundysoft.com. With these files, I should be able to trace the events leading to the bug you may be reporting.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3689
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Re: Mesh decimator error

Postby Aaron » Tue Apr 26, 2011 9:36 am

Hi All,

I've included a fix for this bug in the latest developmental build (v2.9 build 16, from the 26th of April 2011). The installer is on the downloads page now. Please let me know if problems persist.

Cheerio,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3689
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron