L3DT users' community
Large 3D terrain generator

Clipped / Cropped Design Map ? HELP !

Got a problem or need advice?

Clipped / Cropped Design Map ? HELP !

Postby silent303 » Sat Mar 03, 2007 7:56 pm

hi

everytime i generate a design map from a hightmap, or import my heigthmap as a design map eg. 1024x1024 and sample with eg. 64 size, the upper and right corner gets cropped in the design map ? i really dont know why this happens. please help

here is the heightfield with 1024x1024 resolution. you can see that the content has same margin on all corners:

Image



heres the imported heighfield as designmap, 64s samples resolution and on the upper and right side it gets cropped:

Image



heres how i workarounded temporary:


i slighty changed content size by 16pixel (resoulution stil the same) for both direction (for 16x sample size in designmap, for 64x sample size i need to resize by 64 pixel) look at the upper and right corner 16pixel white area.

Image




in designmap now it show right up without cropps:

Image



but this cant be the right way ?

sorry for bad english :D
silent303
Member
 
Posts: 12
Joined: Sat Mar 03, 2007 7:26 pm

Postby silent303 » Sun Mar 04, 2007 3:40 pm

hello again,

does nobody have similar problems with cropped designmaps ???
silent303
Member
 
Posts: 12
Joined: Sat Mar 03, 2007 7:26 pm

Postby Aaron » Sun Mar 04, 2007 8:39 pm

Hi Silent303,

Thanks for the bug report. What's happening here is not clipping, but a systematic offset of 1/2 a pixel. When re-sizing, L3DT is taking its height sample from the lower left of the pixel. That's also why there is a large gap between the left/bottom edges of the map and the features in your image. I've put this on the to-do list to fix, and I'll reply here when it's done.

In the mean-time, you can avoid this artifact by re-sizing the image in a proper image editor. For example, you could resize the first map in PS/etc to a size of 16x16, then import as a design map with a file/DM sample rate of 1.

Best regards,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3691
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby silent303 » Sun Mar 04, 2007 9:33 pm

hi aaron,

thanks alot for reply, i was so long thinking that was my fault :D

silent303
silent303
Member
 
Posts: 12
Joined: Sat Mar 03, 2007 7:26 pm


Return to Help and support

Who is online

Users browsing this forum: No registered users and 0 guests

cron