L3DT users' community
Large 3D terrain generator

2.4 Beta: Errors in the error log

Please report software faults here.

2.4 Beta: Errors in the error log

Postby Qbound » Mon Apr 17, 2006 10:23 am

Hi Aaron,

currently i am working on a 16k*16k Heightmap with 1024pages and edgewarpping. I used some volcanos and mountains. In the error log i got many entries like this one:

CMapWrap::SetPixel error
- invalid index

greetings, Oliver
Qbound
New member
 
Posts: 5
Joined: Mon Apr 10, 2006 9:59 am
Location: Germany

Postby Aaron » Mon Apr 17, 2006 10:55 am

Hi Oliver,

Could you please send the 'debug.dat' file to aaron@bundysoft.com? The file should be in 'C:\Program files\Bundysoft\L3DT 2.4 beta1\'.

Cheers,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3687
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia

Postby Qbound » Mon Apr 17, 2006 3:47 pm

Hi Aaron,

done.

cu
Oliver
Qbound
New member
 
Posts: 5
Joined: Mon Apr 10, 2006 9:59 am
Location: Germany

Postby Aaron » Wed Apr 19, 2006 8:49 am

Thanks Oliver,

Yet again, this looks like the progress display is playing up (see this thread). There were only 21 'CMapWrap::SetPixel' errors in the error log, which is far to few to be a core map operation. To my knowledge the progress-display bug doesn't affected the map output in any way (I'll still look into it anyway, of course). Did the maps come out looking OK after these errors?

As for the other error:

debug.txt wrote:CMapGroup::WMManualFloodCalc error:
- mosaic maps are disabled in this function


Sorry, I haven't implemented the flooding-tool for mosaic maps yet, but it is on the to-do list for the next version.

Cheers,
Aaron.
User avatar
Aaron
Site Admin
 
Posts: 3687
Joined: Sun Nov 20, 2005 2:41 pm
Location: Melbourne, Australia


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron